Delayed inbound emails
Incident Report for Enchant
Resolved
This incident has been resolved.
Posted Jan 08, 2020 - 12:38 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 08, 2020 - 06:11 UTC
Monitoring
We've resolved the underlying issue. All delayed inbound emails have now been processed.

We are continuing to monitor the systems.
Posted Jan 08, 2020 - 05:58 UTC
Identified
We've identified an issue with delayed processing of inbound emails.
Posted Jan 08, 2020 - 05:23 UTC
This incident affected: Email Delivery.